> Source: [sk94845](https://support.checkpoint.com/results/sk/sk94845)

# sk94845 - Deployment of Endpoint Security client fails with error "Failed to download package"

| Property | Value |
|----------|-------|
| Solution ID | sk94845 |
| Date Created | 2013-09-08 |
| Last Modified | 2017-07-30 |
| Technical Level | Advanced |
| Products | Endpoint Security |
| Versions | Cloud, E89.X, E88.X, R82.20, R82.10, R82, R81.20 |

## Symptoms

- * Deployment of Endpoint Security client fails with error "`Failed to download package`".  

* `%DADIR%\logs\cpda.log` file on the Endpoint Security client shows "`errorCode: 28150`".  

* `%DADIR%\logs\cpda.log` file on the Endpoint Security client shows HTTP response code 403.  

* `$UEPMDIR/logs/apache_access.log` file on the Endpoint Security Server shows HTTP response code 403 - `"GET /cp/file/... HTTP/1.1" 403`  

* `$UEPMDIR/logs/apache_error.log` file on the Endpoint Security Server shows "`Permission denied: access to /cp/file/... denied`".

## Cause

Owner "execute" permissions are omitted from `/opt/CPsuite-RXX/` directory and `/opt/CPsuite-RXX/fw1/` directory on Endpoint Security Server. This issue is found after installing any hotfix package on E80 Endpoint Security Server running on Gaia OS.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
