> Source: [sk75340](https://support.checkpoint.com/results/sk/sk75340)

# sk75340 - "Failed to read CA certificate of [CA name] from database" error after software upgrade without reseting SIC

| Property | Value |
|----------|-------|
| Solution ID | sk75340 |
| Date Created | 2012-05-30 |
| Last Modified | 2014-11-20 |
| Technical Level | Advanced |
| Products | Security Management Server |
| Versions | R82.10, R82, R81.20, R82.20 |

## Symptoms

- * After upgrading Management server software, certificate authorities stop working.   

* "Failed to read CA certificate of \[CA name\] from database" error is displayed for ALL the CAs (not only ICA) when trying to view certificates from SmartDashboard.   

* The same happens whether clicking View from gateway's IPSEC VPN tab, or CA in the Servers and OPSEC Applications.

## Cause

Corruption in the Data Base: the *fwauth.NDB* file is missing the*internal_ca* keys section and is unrepeatable.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
