> Source: [sk44665](https://support.checkpoint.com/results/sk/sk44665)

# sk44665 - SNMPGET command fails with the error 'No Such Instance currently exists at this OID'

| Property | Value |
|----------|-------|
| Solution ID | sk44665 |
| Date Created | 2010-04-27 |
| Last Modified | 2025-01-16 |
| Technical Level | Advanced |
| Products | Security Gateway, Security Management Server |
| Versions | R82.10, R82, R81.20, R81.10 (EOS), R82.10, R82, R81.20, R81 (EOS), R81.10 (EOS), R81 (EOS) |

## Symptoms

- SNMPGET command fails with the error '`No Such Instance currently exists at this OID`'

## Cause

SNMPGET command was meant to retrieve individual OID, not a tree - it always sends a GetRequest.

[SNMPGET](http://www.net-snmp.org/docs/man/snmpget.html) command requires the index of the OID:

* for scalar - 0
* for tables - row number

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
