> Source: [sk32936](https://support.checkpoint.com/results/sk/sk32936)

# sk32936 - SmartDashboard shows TCP connectivity error on TCP port 18191, error no. 10 on policy installation failure to Virtual System fails

| Property | Value |
|----------|-------|
| Solution ID | sk32936 |
| Date Created | 2007-04-28 |
| Last Modified | 2019-12-17 |
| Technical Level | Advanced |
| Products | Security Gateway, Spark Firewall (Locally Managed), Hardware |
| Versions | R82.10, R82, R81.20, R82.00.X, R81.10.X, Not Version-Specific |
| OS | Gaia |

## Symptoms

- Policy installation to Virtual System fails with `Reason: TCP connectivity failure ( port = 18191 }{ IP = x.x.x.x } { error no. 10}.` message in SmartDashboard.

## Cause

Possible reasons:

1. Policy is not installed on the VSX Gateway itself (context of VS0).
2. The `$FWDIR/conf/masters` file of the VSX machine contains incorrect information in the \[Policy\] section.
3. Connectivity/routing issues between Management Server and VSX Gateway.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
