> Source: [sk185271](https://support.checkpoint.com/results/sk/sk185271)

# sk185271 - UDP traffic is accepted but dropped after Destination NAT with "fwconn_key_init_links (INBOUND) failed"

| Property | Value |
|----------|-------|
| Solution ID | sk185271 |
| Date Created | 2026-08-17 |
| Last Modified | 2026-09-02 |
| Technical Level | Advanced |
| Products | Security Gateway, Cloud Firewall |
| Versions | R82, R82 |
| OS | Gaia |

## Symptoms

- * UDP traffic matches an Access Control rule with action Accept but does not reach the translated destination.
* Destination NAT is calculated correctly, but the packet is dropped with `fwconn_key_init_links (INBOUND) failed`.
* Kernel debug may show `failed to set the link (-3)` and `fwconn_key_link_collision`.

## Cause

The issue can occur when the reverse link required for a new UDP NAT connection matches an existing UDP connection entry.

For example:

* A device initiates a UDP connection through Destination NAT.
* The translated destination has already initiated UDP traffic back to that device using the same ports.
* The existing connection may therefore use the reverse connection tuple required by the new NAT connection.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
