> Source: [sk184898](https://support.checkpoint.com/results/sk/sk184898)

# sk184898 - HealthCheck Point test "Static Routes with Local IP next hop" consistently reports status [ERROR] on the Security Gateway

| Property | Value |
|----------|-------|
| Solution ID | sk184898 |
| Date Created | 2026-04-17 |
| Last Modified | 2026-04-20 |
| Technical Level | Advanced |
| Products | Security Gateway |
| Versions | R81.20 |
| OS | Gaia |

## Symptoms

- * The HealthCheck Point (HCP) test "Static Routes with Local IP next hop" consistently reports the status `[ERROR]` on the Security Gateway.

* The HCP full report states that static routes are configured with a next hop equal to a local IP address, a cluster Virtual IP address (VIP), or a local interface IP address, which is an unsupported configuration.<br />

* The HCP output includes a routed daemon error similar to:

  `routed0.conf:23 Next hop for static route ` can not be an address assigned to a local interface at 'end-of-statement'
* Reviewing the current static route configuration shows no static routes that use a local interface IP address or cluster VIP as the next hop (for example, clish -c `show configuration static-route` and the current `/etc/routed0.conf` content show only valid next hops).

* After clearing or rotating the file `/var/log/routed_messages` and rerunning the "Static Routes with Local IP next hop" test, the test status changes from `[ERROR]` to `[PASSED] / Result: SUCCESS`.

## Cause

The HCP test "Static Routes with Local IP next hop" scans the file `/var/log/routed_messages` for specific error messages.

The test does not distinguish between historical and current log entries.

If an invalid static route existed in the past and was later corrected, its error message may still remain in the log file. As a result, HCP reports `[ERROR]` even though the current routing configuration is valid.

This behavior leads to a false positive caused by stale routed daemon log entries.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
