> Source: [sk184886](https://support.checkpoint.com/results/sk/sk184886)

# sk184886 - Security Management Server major upgrade fails with Install On rule error

| Property | Value |
|----------|-------|
| Solution ID | sk184886 |
| Date Created | 2026-04-13 |
| Last Modified | 2026-04-14 |
| Technical Level | Advanced |
| Products | Security Management Server |
| Versions | R82, R81.20, R81.10 (EOS) |
| OS | Gaia |

## Symptoms

- * A major version upgrade of the Security Management Server fails during the "Import of User Data\&" phase with these errors:  

  `
  Failed: Upgrade of "SMC User"`  
  `
  `
  and  
  `
  User Data:`  
  `
  Error Message Failed to get installOn column from rule`  
  `
  Objects (number)`

* The failure happens after the system boots into the new version and starts the database import.

## Cause

The management database contains a rule that has no valid value in the Install On (policy target) field. After an upgrade, the system can block policy validation when a rule exists but no applicable target has the required feature enabled.

In this scenario, the rule is an automatically created Mobile Access authorization rule (created by the Mobile Access Wizard) that appears in the Access Control policy. If the rule has an empty Install On field (no target gateways), the import can fail during the upgrade process.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
