> Source: [sk184199](https://support.checkpoint.com/results/sk/sk184199)

# sk184199 - "TypeError: string indices must be integers, not 'str'" error when running "insights" and "show cluster info overview" commands on a Maestro VSX Security Group after upgrade to R82

| Property | Value |
|----------|-------|
| Solution ID | sk184199 |
| Date Created | 2025-11-06 |
| Last Modified | 2025-11-10 |
| Technical Level | Advanced |
| Products | Security Gateway, Scalable Platforms |
| Versions | R82, R81.20, R82, R81.20 |

## Symptoms

- After an upgrade to R82, when running the "`insights`" and "`show cluster info overview`" commands on any Virtual System (VS) other than VS0, the following error appears:

`TypeError: string indices must be integers, not 'str'`  

**Example output in VS1:** ![](https://sc1.checkpoint.com/sc/SolutionsStatics/sk184199/insights_error202510241134581.png)

## Cause

After upgrading the Maestro VSX Security Group to R82, the daemon responsible for collecting `Insights` data is not registered with the VSs. As a result, errors occur when retrieving cluster statistics.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
