> Source: [sk184075](https://support.checkpoint.com/results/sk/sk184075)

# sk184075 - "Error: illegal characters in administrator password hash" when cloning administrator accounts using the "add administrator" command with a password hash

| Property | Value |
|----------|-------|
| Solution ID | sk184075 |
| Date Created | 2025-09-30 |
| Last Modified | 2025-10-27 |
| Technical Level | Advanced |
| Products | Spark Firewall (Locally Managed) |
| Versions | R81.10.X |
| Platform | 1570R, 1575R, 1500, 1900, 2000, 1600, 1800, 1595R |

## Symptoms

- The following error appears when you clone administrator accounts using the `add administrator` command with a password hash:

`Error: illegal characters in administrator password hash`

## Cause

The Clish shell does not support enhanced SHA-512 password hashes that include additional cryptographic parameters.  

Explanation:  

1. Enhanced SHA-512 hashes include salt and rounds, formatted as `$6$rounds=10000$salt$hashed_password.`
2. The Clish parser expects a basic SHA-512 hash without these parameters.
3. The shell interprets these as illegal characters, resulting in `Error: illegal characters in administrator password hash`.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
