> Source: [sk183135](https://support.checkpoint.com/results/sk/sk183135)

# sk183135 - Remote Access VPN users are unable to connect to Spark Firewall due to "Rulebase internal error"

| Property | Value |
|----------|-------|
| Solution ID | sk183135 |
| Date Created | 2025-02-23 |
| Last Modified | 2025-02-27 |
| Technical Level | Advanced |
| Products | Spark Firewall (Locally Managed) |
| Versions | R81.10.X |

## Symptoms

- * Remote Access VPN users cannot connect.

* Logs display the error "*Rulebase internal error*."

## Cause

This issue occurs due to one these reasons:

1. **Corrupted Entry in `metagroup_rules_g` Kernel Table**

   As described in [sk175704](https://support.checkpoint.com/results/sk/sk175704), a corrupted entry in the metagroup_rules_g kernel table causes the Remote Access VPN authentication to fail.
2. **Nested Groups and Permission Limitations**

   * Due to an R81.10.10 code change in the Identity Awareness Blade, Remote Access VPN permissions do not extend to nested groups.

   * The Rule Base includes nested Access Groups or LDAP Groups with Remote Access permissions.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
