> Source: [sk181570](https://support.checkpoint.com/results/sk/sk181570)

# sk181570 - "Unable to start policy installation: Policy installation on a gateway is already queued" error

| Property | Value |
|----------|-------|
| Solution ID | sk181570 |
| Date Created | 2023-10-19 |
| Last Modified | 2024-08-05 |
| Technical Level | Advanced |
| Products | Security Management Server |
| Versions | R81.20, R81.10 (EOS), R81 (EOS) |

## Symptoms

- * After first failed policy installation, it fails to initiate a new policy installation for the same Security Gateway: "`Unable to start policy installation: Policy installation on a gateway <Security Gateway name> is already queued`"  

* Running "`# psql_client cpm postgres -c "select from tasknotification where status is null;`"  

  Retrive "0" results.
* Policy installation using API also fails   

  `code: "err_policy_installation_failed"`  
  `message: "Unable to start policy installation: Policy installation on a gateway <NAME> is already queued"`

## Cause

A task is stuck and should be discarded.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
