> Source: [sk180905](https://support.checkpoint.com/results/sk/sk180905)

# sk180905 - Azure VMSS upgrade fails because it does not find the Load Balancer

| Property | Value |
|----------|-------|
| Solution ID | sk180905 |
| Date Created | 2023-05-07 |
| Last Modified | 2024-07-23 |
| Technical Level | Advanced |
| Products | Cloud Firewall |
| Versions | R82.10, R81.20, R82 |
| OS | Gaia |
| Platform | Azure |

## Symptoms

- * Azure VMSS upgrade fails with error: `"Resource /subscriptions/(Subscription)/resourceGroups/(ReasoureGroup)/providers/Microsoft.Network/loadBalancers/FRONTEND-LB not found."`

* The names of the VMSS environment's Load Balancers are not the default "frontend-lb" or "backend-lb".

## Cause

The Azure marketplace template only accepts Load Balancers with the default name.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
