> Source: [sk179917](https://support.checkpoint.com/results/sk/sk179917)

# sk179917 - "Failed to delete object - (2) Topology: specific network must be defined" error when deleting a Network Group Object

| Property | Value |
|----------|-------|
| Solution ID | sk179917 |
| Date Created | 2022-09-01 |
| Last Modified | 2022-09-03 |
| Technical Level | Advanced |
| Products | Security Management Server, Multi-Domain Security Management Server |
| Versions | R81.10 (EOS), R81.10 (EOS) |

## Symptoms

- * After you change the definition of a cluster object that included a Network Group Object to some other option, this popup error appears when you attempt to delete the unused Network Group Object:

  ```
  
  "Failed to delete object"
  "(2) Topology: specific network must be defined".
  "Please fix these errors before attempting to delete the object."
  ```

* In the "Topology Settings" of the interface, the Network Group Object name appears as the top option (Internal).

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
