> Source: [sk178284](https://support.checkpoint.com/results/sk/sk178284)

# sk178284 - "Timeout was reached" error when a management API command fails 

| Property | Value |
|----------|-------|
| Solution ID | sk178284 |
| Date Created | 2022-03-08 |
| Last Modified | 2023-07-16 |
| Technical Level | Advanced |
| Products | Security Management Server, Multi-Domain Security Management Server |
| Versions | R81.20, R81.10 (EOS), R81 (EOS), R81 (EOS), R81.10 (EOS), R81.20 |

## Symptoms

- A management API command (such as show-groups, show-access-rulebase, show-package and so on), executed locally or by a third party, fails with "*Timeout was reached*" error.

## Cause

There are several factors that cause inflation of the execution duration of API:  
1. Setting `details-level full`.  
2. Setting `use-object-dictionary false`.  
3. The limit parameter is higher than 500.  
4. Setting `show-membership true`.  
5. Setting `dereference-group-members true`.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
