> Source: [sk176664](https://support.checkpoint.com/results/sk/sk176664)

# sk176664 - Cannot create an Access Control policy through the Management API when the service object has the same name as the application object

| Property | Value |
|----------|-------|
| Solution ID | sk176664 |
| Date Created | 2021-12-12 |
| Last Modified | 2022-01-02 |
| Technical Level | General |
| Products | Security Management Server |
| Versions | R81.10 (EOS), R81 (EOS) |

## Symptoms

- * An error occurs when trying to create an Access Control policy through the Management API using a service object with the same name as the application object. In this example, the application object name and service object name are duplicated.  
  *GoToMyPC*   
  *MindTouch*   
  *PostgreSQL*   
  *ProofHQ*   
  *RIPng*   
  *RealPlayer*   
  *Replay AV*   
  *Unknown Traffic*   
  *WinMX*   
  *X11*   
  *iMesh*   
* The Management API shows this error message:  
  "*Requested object name \[xxx\] is not unique.*"

## Cause

The Management API limitation causes objects with duplicate names not to be operated by specifying "name".

## Solution

Use the "UID" instead of the "service object name" to differentiate.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
