> Source: [sk176110](https://support.checkpoint.com/results/sk/sk176110)

# sk176110 - Policy installation on a ROBO gateway fails with error "Unknown Error CPRID #-1"

| Property | Value |
|----------|-------|
| Solution ID | sk176110 |
| Date Created | 2021-11-04 |
| Last Modified | 2022-02-10 |
| Technical Level | Advanced |
| Products | Security Management Server |
| Versions | R81.10 (EOS) |

## Symptoms

- * Policy installation on a ROBO gateway fails with this error in the SmartProvisioning GUI: "*Unknown Error CPRID #-1*"
* Policy installation on the ROBO gateway fails with this error on the gateway side: "*Management rejected fetch for this module - version matching problem.*"

## Cause

When installing policy in R81.10, there should be a file with all the ROBO gateways information, (at `$FWDIR/conf/robo_gateways_for_fetch_policy.C` , in each domain).  

Due to an inconsistency during the upgrade process, the file does not include all relevant Gateways.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
