> Source: [sk169493](https://support.checkpoint.com/results/sk/sk169493)

# sk169493 - Policy installation fails with error "Layer xxx: Rule x has "Legacy User Access" in the Source column which can be configured on layer with Firewall only."

| Property | Value |
|----------|-------|
| Solution ID | sk169493 |
| Date Created | 2020-09-21 |
| Last Modified | 2020-09-29 |
| Technical Level | Advanced |
| Products | Endpoint Security |
| Versions | Cloud, E89.X, E88.X |
| OS | Gaia |

## Symptoms

- * Policy installation fails with error:  
  "Layer xxx: Rule x has "Legacy User Access" in the Source column which can be configured on layer with Firewall only."
* Installing the policy only on firewall policy layer resolves the issue:  
  Security Policies \> Access Control \> right click Policy \> Edit Policy \> Blades \> Edit Layer \> Verify only "Firewall" is checked.

## Cause

There is a limitation in legacy user (user@location). It can **only** be used in layers with "firewall only".

<br />

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
