> Source: [sk169017](https://support.checkpoint.com/results/sk/sk169017)

# sk169017 - SIP traffic is dropped with reason "Too many pending data connections for one control connection"

| Property | Value |
|----------|-------|
| Solution ID | sk169017 |
| Date Created | 2020-11-09 |
| Last Modified | 2023-05-31 |
| Technical Level | Advanced |
| Products | Security Gateway |
| Versions | R81.20, R81.10 (EOS), R81 (EOS) |
| OS | Gaia |

## Symptoms

- * Security Gateway drops new SIP connections with "`Too many pending connections`" error.

* Kernel debug (according to [sk95369](https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solutionid=sk95369) shows:   

  `"; DATE TIME.PID;[cpu_15];[fw4_0];fwconn_lookup_other_ex_legacy_: conn <dir 0, 1.1.1.1:5060 -> 1.1.2.2:5060 IPP 17;"`

## Cause

One of the possible reasons - Early-NAT fails, and a connection from port 5060 to port 5060 was created in the Connections table (table ID 8158). All new pending connections are matched to this connection.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
