> Source: [sk167758](https://support.checkpoint.com/results/sk/sk167758)

# sk167758 - "SIC error 117" when trying to establish SIC

| Property | Value |
|----------|-------|
| Solution ID | sk167758 |
| Date Created | 2020-07-01 |
| Last Modified | 2020-07-05 |
| Technical Level | Advanced |
| Products | Security Management Server, Multi-Domain Security Management Server |
| Versions | R82.10, R82, R81.20, R82.10, R81.20, R82 |
| OS | Gaia |

## Symptoms

- * When trying to establish SIC foloowing error is received:   
  `
  SIC Status for GW: Not Communicating` SIC is not initialized at the peer [error no. 117]  
  Check that peer SIC is configured, and that it has a valid SIC certificate

* Telnet on port 18191/18211 is working

* When attempting to reset the SIC on the SmartConsole, the error appears immediately :   
  `"The SIC was not initialized, cannot continue"`

* If the ICA name for the CLM/CMA was changed, you can review the registry file for this specific customer under the customers folder in the respective CLM/MDS.  

  On the Management server this file is on the $CPDIR/registry/HKLM_registry.data
  you can see that the old name is still there.

* Attempting to copy/create a new file in the registry folder is denied with the following:  
  `
  cp: cannot create regular file 'HKLM_registry.data.backup': Permission denied`

## Cause

The registry folder **or** files under the $CPDIR/registry are attributed with the 'i' flag (Immutable - Prevents any change to file's contents or metadata: file/directory cannot be written to, deleted, renamed, or hard-linked).  

This is rarely caused by a failed backup/MDS_backup but is mostly due to human error.   

This will not allow the new cert to write the SIC name to the registry file properly on the machine you fail to initiate SIC with. (not on the Management server.)  

When the scenario is on Multi-Domain Server/Multi-Log Management, you can see the issue on the customers context:  
`# mdsenv <CLM/CMA_IP>`  
`# mcd`  
`# cd /opt/CPmds-`**R80.xx** `/customers/<CMA_NAME>/CPshrd-`**R80.xx**`/registry`  

<br />

To confirm the issue run the following command in the path according to your version:  
`# lsattr /opt/CPshrd-`**R80.xx**`/registry/HKLM_registry.data`  

The output is, for example in a correct situation:  
` /opt/CPshrd-`**R80.xx**`/registry/HKLM_registry.data`  

Verify the same on the directory itself:  
`# lsattr /opt/CPshrd-`**R80.xx**`/registry`

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
