> Source: [sk151212](https://support.checkpoint.com/results/sk/sk151212)

# sk151212 - invalid domain name error when creating domain object in R80.10

| Property | Value |
|----------|-------|
| Solution ID | sk151212 |
| Date Created | 2019-04-20 |
| Last Modified | 2019-05-06 |
| Technical Level | General |
| Products | Multi-Domain Security Management Server |
| Versions | R82.10, R81.20, R82, R82.20 |
| OS | Gaia |

## Symptoms

- When creating domain object with more than 6 characters as Domain suffix, it will failed with error "invalid domain name" or "Invalid FQDN (Fully qualified domain name)" For example: Domain: "abc.technlogy" this will get error and can not be created Domain: "abc.techno" this will be fine.

## Cause

There is a code limitation for domain suffix when creating domain object and it only allows up to 6 characters.

This issue has been resolved starting from R80_10_jumbo_hf, take 154 and onwards.

## Solution

[Contact Check Point Support](https://www.checkpoint.com/support-services/contact-support/) to get a Hotfix for this issue.   
A Support Engineer will make sure the Hotfix is compatible with your environment before providing the Hotfix.   
For faster resolution and verification please collect [CPinfo](https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solutionid=sk92739) files from the Security Management and Security Gateways involved in the case.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
