> Source: [sk147972](https://support.checkpoint.com/results/sk/sk147972)

# sk147972 - AlgoSec fails to connect to the Security Management Server through OPSEC after an upgrade to R80.10

| Property | Value |
|----------|-------|
| Solution ID | sk147972 |
| Date Created | 2019-03-06 |
| Last Modified | 2019-03-07 |
| Technical Level | Advanced |
| Products | Security Management Server |
| Versions | R82.10, R82, R81.20, R82.20 |
| OS | Gaia |

## Symptoms

- After a successful upgrade of the Security Management Server to R80.10, the integration with AlgoSec through OPSEC fails to fetch the requested logs. (The SIC certificate for OPSEC communication is being pulled successfully from the Security Management Server by the AlgoSec server.)

## Cause

AlgoSec uses R80.x Management API for general communication. The AlgoSec server needs to be in the list of allowed IP addresses that can connect through the API.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
