> Source: [sk143812](https://support.checkpoint.com/results/sk/sk143812)

# sk143812 - CloudGuard service registration fails with "FAILED TO CREATE SERVICE"

| Property | Value |
|----------|-------|
| Solution ID | sk143812 |
| Date Created | 2019-01-09 |
| Last Modified | 2019-01-10 |
| Technical Level | Advanced |
| Products | Cloud Firewall |
| Versions | R82.10, R81.20, R82 |

## Symptoms

- * The issue with the failed service registration starts after the user installs the VSR5 hotfix on top of VSR4.
* The following is the error message related to the issue in *vsec_config.elg* :

## Cause

The user did not uninstall VSR4 before installing the VSR5 hotfix, resulting in an incorrect upgrade path to VSR5. This prevented the replacement of the configuration file.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
