> Source: [sk130033](https://support.checkpoint.com/results/sk/sk130033)

# sk130033 - "Main Mode I have no certificate to use for IKE" error message when VPN negotiation fails

| Property | Value |
|----------|-------|
| Solution ID | sk130033 |
| Date Created | 2018-06-20 |
| Last Modified | 2020-10-26 |
| Technical Level | Advanced |
| OS | Gaia |

## Symptoms

- * After migrate export to new machines, VPN negotiation fails with the error "Main Mode I have no certificate to use for IKE".
* When collecting VPN debugs during policy push the following error is seen in *vpnd.elg* on one of the trusted CA's:  
  "fwCertOfCAObj: can't find keyset of Trusted-CA-NAME"

## Cause

This is caused due to a database corruption. The Trusted CA object is broken and it affects all the certificate authorities.

**Note:** Even though the Broken CA is not used for the VPN negotiation it still affects it.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
