> Source: [sk124152](https://support.checkpoint.com/results/sk/sk124152)

# sk124152 - "Empty old password for admin not allowed" error  message when "Reset local Administrator password" fails

| Property | Value |
|----------|-------|
| Solution ID | sk124152 |
| Date Created | 2018-04-16 |
| Last Modified | 2018-04-22 |
| Technical Level | Advanced |
| Products | Security Gateway, Security Management Server |
| Versions | R82.10, R82, R81.20, R82.10, R82, R81.20, R82.20 |
| OS | Gaia |

## Symptoms

- * "Reset local Administrator password" in IPSO fails with "Empty old password for admin not allowed" error when using either Voyager or CLI. (Same behavior is observed in GAIA OS.)
* A non-Super User that was logged in (e.g. Radius Authenticated Administrator) was used to try to reset the Local Administrator password (which is a Super User).

## Cause

**Only user with UID 0 (Super User) is allowed to reset Local Administrator password.**

The logged in user that is used to reset the Local Administrator password does not have the required Super User permissions.

A Radius Administrator has a UID of "1" by design, and thus is not allowed to reset the password.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
