> Source: [sk123313](https://support.checkpoint.com/results/sk/sk123313)

# sk123313 - Performance improvements accumulator for Management HA in R80.10

| Property | Value |
|----------|-------|
| Solution ID | sk123313 |
| Date Created | 2018-03-14 |
| Last Modified | 2019-05-07 |
| Technical Level | Advanced |
| Products | Security Management Server, Multi-Domain Security Management Server |
| Versions | R82.10, R82, R81.20, R82.10, R81.20, R82 |

## Symptoms

- * CMA/CLM creation fails with error:  

  "`Failed to create Domain server {DOMAIN_SERVER_NAME} `  
  `
  Failed to connect to remote MDS {MDS_NAME} that holds the active Domain server`  
  `
  Check the connection with the remote MDS`" error.  

* "`FWM mainloop wasn't available for ...`" message is frequently printed in the `$MDS_FWDIR/log/mds.elg` log file.  

* When publishing a session, it takes a long time until the changes are shown on a Secondary Management / Multi-Domain Management server.
* In an MDS HA environment the primary MDS becomes unresponsive after a certain period of time. The only way to restore functionality is to reboot the MDS machine.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
