> Source: [sk120032](https://support.checkpoint.com/results/sk/sk120032)

# sk120032 - System moves to a Read-Only File-system

| Property | Value |
|----------|-------|
| Solution ID | sk120032 |
| Date Created | 2017-08-16 |
| Last Modified | 2017-09-12 |
| Technical Level | Advanced |
| Products | Security Gateway, Security Management Server |
| Versions | R82.10, R82, R81.20, R82.10, R82, R81.20 |
| OS | Gaia |

## Symptoms

- * Unable to log into Security Gateway / Management Console. Receive error:  
  `"sh: tmp_env_vars: Read-only file system
  CLINFR0139 Couldn^t open the tmp_env_vars: No such file or directory"`
* Policy push fails with "SIC error 148".
* The command: 'cat /proc/mounts' shows partition with RO in line.

## Cause

**Scenario 1**

Linux has a feature called **Storage drive timeout** that is used when the Raid/Controller or Linux is not able to communicate with a drive to read/write to it.

Check Point has a timeout for its storage drive hold that tells linux how long to wait for the drive to respond (This timeout is by default 60 centiseconds or .6 seconds in Gaia) before it marks the drive unreachable and marks it as read only to protect it from corruption.

These communications issues will happen when the drive is already tasked with a read/write operation and is not able to complete it in time to process other requests such as the controller check.

**Scenario 2**

Issues when Disk read/write operations are slow and causing the system to go read-only could also be due to a failing Hard Drive.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
