> Source: [sk113748](https://support.checkpoint.com/results/sk/sk113748)

# sk113748 - "Internal Error: Failed to update Database object" error in SmartDashboard when updating IPS

| Property | Value |
|----------|-------|
| Solution ID | sk113748 |
| Date Created | 2016-10-06 |
| Last Modified | 2018-07-18 |
| Technical Level | Advanced |
| Products | Security Gateway, Security Management Server, Multi-Domain Security Management Server |
| Versions | R82.10, R82, R81.20, R82.10, R82, R81.20, R82.10, R82.20, R81.20, R82, R82.20 |

## Symptoms

- * "`Internal Error: Failed to update Database object`" error in SmartDashboard when updating IPS.

  *Example* :  

  ![](https://sc1.checkpoint.com/sc/SolutionsStatics/sk113748/Error.jpg)
* Policy Installation fails after even with IPS blade is disabled.

* Creating a new policy package does not help.

## Cause

IPS database corruption.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
