> Source: [sk113422](https://support.checkpoint.com/results/sk/sk113422)

# sk113422 - "&lt;Name_of_Package&gt;.i386.rpm cannot be opened. This is due to a missing file or perhaps a corrupt package." error at the end of the Gaia OS installation on IP Appliance

| Property | Value |
|----------|-------|
| Solution ID | sk113422 |
| Date Created | 2016-09-22 |
| Last Modified | 2016-09-22 |
| Technical Level | General |
| OS | Gaia |

## Symptoms

- "`<Name_of_Package>.i386.rpm cannot be opened. This is due to a missing file or perhaps a corrupt package.`" error at the end of the clean Gaia OS installation on IP Appliance.
*Example* :  
`logrotate-3.7.4-7.i386.rpm cannot be opened. This is due to a missing file or perhaps a corrupt package. Please verify your mirror contains all required packages, and try using a different one. If you reboot, your system will be left in an inconsistent state that will likely require re-installation.`

## Cause

* The "`copyrpms.bat`" has not been executed on a Windows-based FTP Server, where the Clean Install ISO image resides. Hence, the RPM packages are not copied/missed.
* Corrupted ISO image on the FTP Server.
* Wrong permissions for the FTP User Account on the FTP Server.

## Solution

* **The "`copyrpms.bat`" has not been executed on a Windows-based FTP Server, where the Clean Install ISO image resides.**

  1. Upload the Gaia OS ISO image to the Windows-based FTP Server.
  2. Extract the Gaia ISO to a folder on the FTP Server.
  3. In that folder, run the batch "`copyrpms.bat`"  
     This batch file copies the installation files to provide a required workaround for Windows OS inability to support soft links.  
     Check that you are not getting any "`Access Denied`" messages. Otherwise, the batch would not be executed completely.

  Note: If for some reason you are unable to run the batch "`copyrpms.bat`", i.e., no enough permissions for the user account, or there is no access to the FTP server, then do the following inside the folder, where you have extracted the ISO image:
  1. Manually copy all folders and files from `\system\upg_all\RPMS\` folder to `\system\RPMS\` folder
  2. Manually copy all folders and files from `\Linux\` folder to `\system\RPMS\` folder
  3. Verify that none of the RPM packages in the `\system\RPMS\` folder has a 0 (zero) size
* **Corrupted ISO image on the FTP Server.**

  Compare the MD5 checksum of ISO image on the FTP Server to MD5 checksum on Check Point Download Center.
* **Wrong permissions for the FTP User Account on the FTP Server.**

  Add the FTP Account you are using for the installation, so the folder can be accessed via this FTP Account:  
  Right-click on the folder where the Clean Install ISO image resides - click on *Properties* - go to *Security* tab.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
