> Source: [sk112859](https://support.checkpoint.com/results/sk/sk112859)

# sk112859 - Remote Access Clients immediately receive a "connection failed" notification after a MEP Security Gateway was removed from the Remote Access Community

| Property | Value |
|----------|-------|
| Solution ID | sk112859 |
| Date Created | 2016-08-13 |
| Last Modified | 2022-03-12 |
| Technical Level | General |
| Products | Endpoint Security |
| Versions | Cloud, E89.X, E88.X |

## Symptoms

- * Remote Access Clients immediately receive a `"connection failed"` notification after a MEP gateway was removed from the Remote Access Community.
* Customer is using MEP in load sharing mode, automatic MEP is false and secondary connect is false.
* An old gateway was removed from the Remote Access community and the object was deleted from the SmartDashboard.
* After client restart, client is unable to connect.

## Cause

When client connects, it receives new topology and deletes the removed network object from the gateways list, but the Security Gateway's object name remains in the attributes "original_gw" and "preferred_gw" in the trac.config file of the client.  
After client restart, client is unable to connect because it looks for the Security Gateway written in the *'original_gw'* attribute in his gateway list and this gateway does not exist in the list anymore.

## Solution

This problem was fixed. The fix is included starting from:

* [Endpoint Security E80.82](https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solutionid=sk117536&partition=Basic&product=Endpoint)

Check Point recommends to always upgrade to the most recent version ([Security Gateway](https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doShowproductpage&productTab=downloads&product=435) / [VSX](https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doShowproductpage&productTab=downloads&product=359) / [Security Management Server](https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doShowproductpage&productTab=downloads&product=184) / [Multi-Domain Security Management Server](https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doShowproductpage&productTab=downloads&product=166) / [SmartConsole](https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doShowproductpage&productTab=downloads&product=191)).

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
