> Source: [sk112205](https://support.checkpoint.com/results/sk/sk112205)

# sk112205 - Policy installation on Security Gateway fails with "#define NON_VPN_TRAFFIC_RULES" error

| Property | Value |
|----------|-------|
| Solution ID | sk112205 |
| Date Created | 2016-07-01 |
| Last Modified | 2016-07-05 |
| Technical Level | Advanced |
| Products | Security Gateway, Security Management Server, SmartConsole, Multi-Domain Security Management Server |
| Versions | R82.10, R82, R81.20, R82.10, R82, R81.20, R82.10, R82.10, R82.20, R82.20, R82, R81.20, R81.20, R82, R82.20 |

## Symptoms

- * On the security policy compilation stage there is an error:  
  "#define NON_VPN_TRAFFIC_RULES ((dst=x.x.x.x) or (dst=x.x.x.x))"
* Policy Installation fails - Compilation failed. Operation ended with errors.
* Administrator has defined NON_VPN_TRAFFIC_RULES manually in user.def file.
* user.def file is replaced with older configuration.

## Cause

Administrator manually edited the user.def file in an incorrect location on the Security Management Server.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
