> Source: [sk111052](https://support.checkpoint.com/results/sk/sk111052)

# sk111052 - "A write operation was executed while Certificate Authority is running in read only mode. Operation failed." error in Security Management HA Configuration

| Property | Value |
|----------|-------|
| Solution ID | sk111052 |
| Date Created | 2016-04-16 |
| Last Modified | 2017-08-07 |
| Technical Level | Advanced |
| Products | Security Management Server |
| Versions | R82.10, R82, R81.20 |

## Symptoms

- "A write operation was executed while Certificate Authority is running in read only mode. Operation failed." error shows up only in a Security Management High Availability configuration while trying to reset SIC

## Cause

If the *$FWDIR/conf/mgmtha.conf* file is corrupted or empty, the primary Security Management server will not be able to extract information regarding the status of the local machine. To ensure that the ICA database does not get corrupted, it is locked into a read-only mode.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
