> Source: [sk110789](https://support.checkpoint.com/results/sk/sk110789)

# sk110789 - "CPRID - Fatal error on the peer gateway" error when pushing policy from SmartProvisioning GUI

| Property | Value |
|----------|-------|
| Solution ID | sk110789 |
| Date Created | 2016-03-31 |
| Last Modified | 2024-03-27 |
| Technical Level | Advanced |
| Products | Security Management Server, Spark Firewall (Locally Managed) |
| Versions | R81.20, R81.10.X, R81.10 (EOS), R81 (EOS) |
| OS | Gaia |
| Platform | 1500, 1600, 1800 |

## Symptoms

- * "CPRID -- Fatal error on the peer gateway" error appears when pushing policy from SmartProvisioning GUI.
* QoS blade is enabled for on the LSM Profile.
* The security policy is actually successfully installed on the device, the QoS policy is not installed.

## Cause

QoS blade was activated on the LSM profile for Small Office Appliance Gateway, however QoS Policy can not be applied to any network interfaces, because QoS settings were not configures on any Internet Connection (pre-requisite).

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
