> Source: [sk110779](https://support.checkpoint.com/results/sk/sk110779)

# sk110779 - "curl: (900) servercert: Error - server certificate validation failed!" when running "curl_cli" command

| Property | Value |
|----------|-------|
| Solution ID | sk110779 |
| Date Created | 2016-03-30 |
| Last Modified | 2021-08-31 |
| Technical Level | Advanced |
| Products | Security Gateway, Security Management Server, Multi-Domain Security Management Server |
| Versions | R81.10 (EOS), R81 (EOS), R81.10 (EOS), R81 (EOS), R81 (EOS), R81.10 (EOS) |
| OS | Gaia |

## Symptoms

- * `curl_cli` command fails with the following error when troubleshooting access to Check Point servers per [sk83520](https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solutionid=sk83520):  
  `curl: (900) servercert: Error - server certificate validation failed!`  

* When running the `export TDERROR_ALL_ALL=5` command and then the `curl_cli` command, it shows:  
  `CA bundle file doesn't exist: /usr/share/ssl/certs/ca-bundle.crt`

## Cause

The */usr/share/ssl/certs/ca-bundle.crt* file, which is used for server certificate validation, is the default certificate bundle that curl looks for when the --cacert option was not used.

This error may also occur if the date and time on the server are incorrect.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
