> Source: [sk109112](https://support.checkpoint.com/results/sk/sk109112)

# sk109112 - "vsx_util add_member"command fails with "Failed to write network objects for topology to Check Point database"

| Property | Value |
|----------|-------|
| Solution ID | sk109112 |
| Date Created | 2015-12-15 |
| Last Modified | 2022-12-18 |
| Technical Level | Advanced |
| Products | Security Management Server, Multi-Domain Security Management Server |
| Versions | R81.20, R81.10 (EOS), R81 (EOS), R81 (EOS), R81.10 (EOS), R81.20 |

## Symptoms

- * "*vsx_util add_member* " command fails with the following error message:  

  ``Failed add member operation for `NAME_of_VSX_CLUSTER` :Failed to write network objects for topology to Check Point database``

* Debug of FWM daemon (per [sk33207](https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solutionid=sk33207)) on the Main Domain Management Server (that manages VSX cluster object) shows:  

  ``CSrvObj::Update - Internal error: Cannot get object `NETWORK_OBJECT_NAME` from table network_objects
  Object with the name `SAME_NETWORK_OBJECT_NAME_IN_DIFFERENT_CASE` already exists'``

  *Example:*   

  `Internal error: Cannot get object Net_22.22.22.22 from table network_objectsObject with the name 'NET_22.22.22.22' already exists`

  <br />

## Cause

It appears that a network object with the same name is used in the management database.

The CPMI protocol, which is used by the FWM daemon to write information to the management database, is not case-sensitive. Therefore, two network objects with the same name cannot be written into the database (the name "*GATEWAY* " will conflict with the name "*gateway*").

This is a known limitation.

For example : When a Virtual System is created in the newly added VSX cluster member, automatic topology creates network objects to define topology of VS interfaces. Default naming policy for these network objects is "Net_\<network_IP\>". If a network object "NET_\<network_IP\> already exists (same name, in different case), the automatic network object cannot be created and fails.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
