> Source: [sk108253](https://support.checkpoint.com/results/sk/sk108253)

# sk108253 - "The connection to the Security Management Server &lt;IP address&gt; has been refused because the database could not be opened" error when trying to view database revision

| Property | Value |
|----------|-------|
| Solution ID | sk108253 |
| Date Created | 2015-10-29 |
| Last Modified | 2020-05-23 |
| Technical Level | Advanced |
| Products | Security Management Server, SmartConsole |
| Versions | R82.10, R82, R81.20, R82.10, R82, R81.20 |
| OS | Gaia |

## Symptoms

- * "The connection to the Security Management Server \<IP address\> has been refused because the database could not be opened" error pops up when trying to view a database revision.  

* Creating a new database revision / reverting to an older database revision works.
* "The connection to the Security Management Server has been refused because the database could not be opened" pops up when trying to connect with SmartDashboard to the Security Management Server.

## Cause

The root cause for the issue is a large database.

When trying to view a database revision, the FWM process generates *CPMILinksMgr.db* cache files for each database revision in *$FWDIR/conf/db_versions/databases/\<Database revision ID\>* directory. Since the database is large, the *CPMILinksMgr.db* file is also large and this causes the connection to time out.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
