> Source: [sk106339](https://support.checkpoint.com/results/sk/sk106339)

# sk106339 - "Cannot establish connection to SSL Network Extender gateway. Try to reconnect." error in SNX Portal after logging in

| Property | Value |
|----------|-------|
| Solution ID | sk106339 |
| Date Created | 2015-06-04 |
| Last Modified | 2024-09-24 |
| Technical Level | Advanced |
| Products | Security Gateway |
| Versions | R82.10, R82, R81.20 |

## Symptoms

- * SNX Portal does not work after Security Gateway upgrade - it allows login, but an error appears:  

  "`Cannot establish connection to SSL Network Extender gateway. Try to reconnect.`"

* There is a 3rd party certificate added in IPsec VPN blade.

* SNX Portal works as expected if all other portals are disabled (e.g., Identity Awareness Web Authentication Portal).

## Cause

IPSec VPN blade recognizes only ICA certificate.

Since IPSec VPN Blade does not recognizes the 3rd party certificate used, it rejects SNX connection that uses 3rd party certificate.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
