> Source: [sk105217](https://support.checkpoint.com/results/sk/sk105217)

# sk105217 - "Commit function failed"/"Installation failed" error on policy installation failure on SMB appliances

| Property | Value |
|----------|-------|
| Solution ID | sk105217 |
| Date Created | 2015-03-15 |
| Last Modified | 2024-01-08 |
| Technical Level | Advanced |
| Products | Spark Firewall (Locally Managed), Security Management Server |
| Versions | R81.10.X, R81.10 (EOS), R81 (EOS) |
| Platform | 1500, 1600, 1800 |

## Symptoms

- * Policy installation on Centrally managed SMB appliances fails with "`Commit function failed`" error when the IPS "Recommended Protection" or a manually created IPS profile is assigned to the Gateway.
* Policy installation on a 1430/1450 appliance in IPv6 mode fails with error "`Installation Failed. Reason: Failed to load Policy on Security Gateway`" when the IPS "Optimized Profile" (existing on R80.x Security Management Servers) or a manually created IPS profile is assigned to the 1430/1450 appliance object.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
