> Source: [sk102791](https://support.checkpoint.com/results/sk/sk102791)

# sk102791 - Snapshot on all platforms fails with "Invalidating snapshot: Unable to allocate exception" error

| Property | Value |
|----------|-------|
| Solution ID | sk102791 |
| Date Created | 2014-10-18 |
| Last Modified | 2018-11-24 |
| Technical Level | Advanced |
| Products | Security Management Server, Multi-Domain Security Management Server |
| Versions | R82.10, R82, R81.20, R82.10, R82.20, R81.20, R82, R82.20 |
| OS | Gaia |

## Symptoms

- Security Management server / MDS Snapshot fails with the following errors in `/var/log/messages`:  

* "kernel: device-mapper: snapshots: Invalidating snapshot: Unable to allocate exception".  

* "kernel: Buffer I/O error on device dm-8, logical block 1298066".  

* "kernel: Buffer I/O error on device dm-8, logical block 1298067".  

* "kernel: Buffer I/O error on device dm-8, logical block 1298068".

## Cause

This problem happens when the snapshot is big and lots of changes happen on the system during the creation of the snapshot.

In these cases, the CoW table, responsible for saving all the changes that are done during the snapshot operation - gets filled and returns the error message.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
