> Source: [sk102050](https://support.checkpoint.com/results/sk/sk102050)

# sk102050 - "Upgrade to this version from current version is prohibited" error on upgrade failure

| Property | Value |
|----------|-------|
| Solution ID | sk102050 |
| Date Created | 2014-08-15 |
| Last Modified | 2014-08-17 |
| Technical Level | Advanced |
| Products | Security Gateway, Security Management Server |
| Versions | R82.10, R82, R81.20, R82.10, R82, R81.20 |
| OS | Gaia |

## Symptoms

- * An upgrade using the Check Point Upgrade Service Engine fails with "Upgrade to this version from current version is prohibited" error.
* According to the [Check Point Upgrade Map](http://downloads.checkpoint.com/dc/download.htm?ID=18761), the upgrade should be allowed.

## Cause

The "LastMinorVersion" attribute in the registry does not have a value or is set incorrectly.

## Solution

This solution requires authentication. Please log in to view the full solution.

---

# Agent Instructions

This content is from the Check Point Support Center (https://support.checkpoint.com), the official knowledge base for Check Point cybersecurity products.

## Navigating This Knowledge Base

- **Complete index**: [llms.txt](https://support.checkpoint.com/llms.txt)
- **All SK articles**: [SecureKnowledge Sitemap](https://support.checkpoint.com/sitemaps/secureknowledge-sitemap-index.xml)
- **SK article URL pattern**: `https://support.checkpoint.com/results/sk/{skId}`
- **Markdown responses**: AI bot User-Agents automatically receive `text/markdown` content
